Page 1 of 1

New forum breaks old links

Posted: Thu Feb 05, 2009 2:16 am
by Olivier
Hi Karl,

I was just wondering if there's a reason the forum got moved out of the /forum directory?

I've got a few threads bookmarked, and I've also somewhat shamelessly pimped Apositive on AVEN when discussion turns to topics that have already been discussed here (often in way too much detail to summarise there). Now that the /forum has disappeared from the URLs, all those links are broken.

So I was just wondering if there's an easy fix at your end. It's not a huge amount of stuff, so if it can't be done I could always go back and edit stuff I've posted that links here (and I probably would, becuase I think anything that gets this site traffic is worth it) but I'd sort of rather, you know, not :) Call me lazy ;)

I love the look of the new site although I'm still feeling my way around where everything lives.

Re: New forum breaks old links

Posted: Thu Feb 05, 2009 5:16 am
by Karl
This happened because the entire site is now one piece of software and so exists within the root directory. If it had been left installed in the /forum/ directory then wewouldn't have had a homepage, and I really wanted the portal to take on that role for the site.

Sorry for the inconvenience, but I figured that we are still a young site and we haven't seen a great deal of activity recently, so the damage relating to existing links would be minimal. Thanks for all your shameless promotion of the site, also, but I'm afraid there's no easy quick fix to correct all those links. If I was to try to move the forum part of the software back into another directory then I'd probably screw the whole thing up.

Re: New forum breaks old links

Posted: Thu Feb 05, 2009 10:21 am
by wintermute
if you're handy with mod_rewrite you could redirect links back to the relevant new link...

however that's more trouble then it's worth :)

Re: New forum breaks old links

Posted: Thu Feb 05, 2009 10:52 am
by Karl
See, I don't even know what that is. What is it?

Re: New forum breaks old links

Posted: Thu Feb 05, 2009 3:36 pm
by wintermute
it's a module for apache that lets you redirect URLs based on specific rules, so you could let links to old threads through, but links to searches and whatnot are directed to a page asking someone to update their bookmarks and then in 15 second send them on to their search or whatever.

http://www.workingwith.me.uk/articles/s ... od_rewrite there's a tutorial on it.

It's most commonly used to send parameters to a script but make it look like it's a subdirectory - so instead of http://www.myblog.com/index.php?year=20 ... =feb&day=4
you can go
http://www.myblog.com/2009/feb/04/

It's more trouble then it's worth in this case :)

edit: turns out that's a real site, don't click the links unless you like 404 errors.

Re: New forum breaks old links

Posted: Thu Feb 05, 2009 4:36 pm
by Karl
Aha! Thanks for the info. It looks like I don't have that Apache module installed on the server right now, but if it's worth doing then I can always request that they install it for me.

Re: New forum breaks old links

Posted: Thu Feb 05, 2009 7:39 pm
by Olivier
Thanks for looking into it - I'll just update the old links as I find them :)